Apple Updates Final Cut Pro X, Compressor, Motion 5 for 4K Video, New Mac Pro

2

Comments

+ Add a Comment
avatar

Bruce Burbank

Couldn't update my FCPX because "Mac OS X version 10.9 or later is required."

avatar

Carsten Legaard

I had these updates visible for around 30 seconds today. Then they disappeared from the app store and never showed up again. I tried update in both my own european app store and the U.S. app store, same same

Log in to Mac|Life directly or log in using Facebook

Forgot your username or password?
Click here for help.

Login with Facebook
Log in using Facebook to share comments and articles easily with your Facebook feed.